Colpittsoscillator till QRP-sändare

SA7CNG

Well-Known Member
Efter att ha labbat runt lite lyckades jag få ihop en fungerande Colpittsoscillator för 7023kHz. Den svänger fint och vågformen ser relativt jämn ut.

Eftersom detta blev så förträffligt bra, började jag fundera på om jag kan koppla på ett "effektsteg" för att kunna köra QRP-CW, alltså 500mW eller ngt i den stilen i en 50ohms last.

Är det någon som kan hjälpa mig i rätt riktning med detta experiment?



img029.jpg

DSC_0924.jpg


DSC_0926.jpg
 

SA7CNG

Well-Known Member
Jag gjorde lite experiment med att designa en egen Class A förstärkare, och lyckades förstärka signalen ca 10ggr, dock drog detta ner kvaliten på sinusvågen kraftigt. Jag försökte få Bas-Emitter spänningen att ligga på 0,65V så att transistorn skulle ligga i sitt linjära område, men detta var inte helt okomplicerat, lägre spänningar gav högre förstkrning av någon anledning.

Det gick tyvärr inte att ansluta en konstlast, kretsen gav inte någon användbar uteffekt utan kollapsade bara vågformens kvalite.
 
Last edited:

SA7CNG

Well-Known Member
Jag har lyckats sätta ihop en class A förstärkare enligt bild, och den förstärker signalen till det dubbla, ca 20mV topp-topp värde, jag hade dock förväntat mig betydligt mer. Resultatet ser inte vacker ut heller, sinuskurvan är väldigt kantig.
DSC_0929.jpg


amp.png
 

SM7NTJ

Well-Known Member
Hej
Det var många år sedan jag beräknade arbetspunkten för ett transistorsteg.
Jag känner inte igen mig i valet av motstånden för ingångssidan. Mitt minne vill ha lite större värden på ingångssidans motstånd och en lägre ström där för att få en bättre arbetspunkt. Jag har även ett minne av att motståndet mellan bas och minus borde ha ett större värde än emittermotståndet för att det ska fungera bra.

Jag kan förstås minnas helt fel och det numera finns andra dimensioneringsteorier för arbetspunkten, för det här har jag inte pysslat med på länge. Jag får ta fram någon gammal mossig bok i hyllan och fräscha upp mitt minne eller söka på nätet efter transistorkopplingens grunder.

73 sw SM7NTJ Lorentz
 

SM0GLD

Vänsterhänt
Du kan gott höja R2, R3 en 10-potens. Finns ingen anledning att slösa 15mA i spänningsdelaren.
Vilket värde har du på kondensatorerna?
Vilken lastimpedans har du på utgången?
 

SM7PNV

Well-Known Member
Du kan titta på Pixi sändaren och ta efter den konstruktionen.
Den har en enkel NPN med jordad emitter och drossel på kollektorn, ger ca 400mW.
Kör i Class C. Du behöver ett lågpassfilter i vilket fall som helst för att ta bort övertonerna så du behöver inte oroa dig med att utsignalen skall vara en snygg sinus.

Om du har en 2n3866 hemma så kan du använda den här kopplingen för att få ut 1Watt
https://www.george-smart.co.uk/wiki/1W_PA_for_10MHz
Den fungerar fint och är enkel att bygga. För Drosslar använd Ferrit Material 43 eller 61

///Harry
 
Last edited:

SM7NTJ

Well-Known Member
Hej
Jo allt är enkelt när man kan eller kommer ihåg.

Så det var bara att gräva fram en gammal mossig bok i hyllan och sökta en kort stund på nätet.

Den här länken kan kanske hjälpa till med dimensioneringen?http://web.kristinehamn.se/skola/anders/analoga_kretsar/forstarkare.doc
http://web.kristinehamn.se/skola/anders/analoga_kretsar/forstarkare.doc

Ett snabbt överslag ger 5,8k istället för 600 ohm och 2,8k istället för 210 ohm.
Översatt till standardvärden borde 5,6k och 3,3 k ge ett bättre slutresultat.

Nyttigt för mig att behöva läsa på lite igen då jag mest ägnat mig åt andra linjära kopplingar och diverse logik sen jag senast räknade på klass A förstärkare.

Lycka till med byggandet 73 de SM7NTJ Lorentz
 

SA7CNG

Well-Known Member
Kondensatorerna för filtrering av signalen(DC-Spärr) är 10nF, C1 är på 470pF(dennas funktion är lite oklar eftersom jag tycker att dom mest ser ut att jorda ner signalen). Jag provade med föreslagna motstånd, men fick försärkning 1:1 med väldigt skum vågform. Av någon anledning så ser det ut som att UB
 

SM5KYH

Well-Known Member
Om du syftar på C1 i DITT kretsschema så är denna avkopplung av emittermotståndet till för att höja förstärkningen på hf
 

SM0GLD

Vänsterhänt
C1 är på 470pF(dennas funktion är lite oklar eftersom jag tycker att dom mest ser ut att jorda ner signalen).
C1 skall vara 100nF för att din koppling ska få någon förstärkning vid 7MHz.


2N2222A.jpg
Min koppling.
tek00168.jpg
Insignal 10mV p-p

tek00169.jpg
Insignal 100mV p-p

tek00170.jpg
Insignal 460mV p-p

Jag lastade förstärkaren med 56 ohm.


2N2222A_sim.jpg
Jag stoppade in en drossel till kollektorn, fick något högre gain.

Mätresultatet stämmer mycket väl med simulerade resultat.
 
Last edited:

SA7CNG

Well-Known Member
Tack för hjälpen!

Jag har försökt skapa en kopia av din krets SM0GLD, men har inte lyckats att få den att förstärka. Det enda som händer hitils är att insignalen blir distorterad av någon anledning. Jag har svårt att få spänningen mellan Bas och Emitter att hamna på 0,65v, med en vridpotentiometer är det nästan omöjligt att ställa in denna, hoppar direkt från 0.5 till 0,7v av någon anledning.

Om jag kopplar bort själva Oscillatorn hamnar Bas-Emitter spänningen direkt på 0.6V, med oscillatorn inkopplad blir den 0.03v och förstärker inget. Detta trots att jag använder en 100nf kondensator för att avskila likspänningsnivåerna mellan kretsarna.

Med ett motstånd i serie med 100nf kondensatorn i "signal in" till slutsteget räddas signalkvaliten upp och spänningen blir 0.6v över Bas-Emitter, men förstärkningen uteblir trots det.

Är det så enkelt att min oscillator inte "orkar" driva slutsteget?

Jag ska göra nya försök när jag fått tag i komponenter med rättare värden(ser ut som ett kråkbo för tillfället).

DSC_0932.jpg
 
Last edited:

SM0GLD

Vänsterhänt
Om jag kopplar bort själva Oscillatorn hamnar Bas-Emitter spänningen direkt på 0.6V, med oscillatorn inkopplad blir den 0.03v och förstärker inget. Detta trots att jag använder en 100nf kondensator för att avskila likspänningsnivåerna mellan kretsarna.
Är kondensatorn hel? det låter som du har kortis i den eller kanske har du lyckats få självsvängning på någon annan frekvens.
 

SM7NTJ

Well-Known Member
Hej

När förstärkaren är i vila så kan du mäta likspänningsnivåer med i stort sett vilket instrument som helst.
Du kommer då att få en spänning mellan bas-emitter som ligger någonstans mellan 0,6 till 0,7 volt.

Denna spänning varierar med transistortyp och exemplar samt är beroende på strömmen. Förhållande mellan spänning och ström bildar en kurva som är "knäformad" det vill säga liten ändring i början sedan en mycket kraftig förändring när knät passeras.

Däremot när förstärkaren är aktiv så kan du inte mäta spänningen hur som helst med vilket mätinstrument som helst då spänningarna runt transistorn består av en växelspänning som är överlagrad på en likspänning.

En fråga, hur många kopplingskondensatorer har du i kretsen? Du behöver bara en mellan varje del för att skilja delarna likströmsmässigt åt.

73 de SM7NTJ Lorentz
 

SA7CNG

Well-Known Member
Det var också min tanke, men efter lite tester verkar det som att denna är intakt, provat med flera andra och fått liknande resultat.

Det verkar som att det är spänningen mellan Emitter-Jord som driver upp när oscillatorn är inkopplad.

Det är två saker som förbryllar mig särskilt, jag får 1:1 förstärkning trots att transistorn är stängd, Spänningen Bas-Emitter = 0. Denna borde vara 0. Och slutsteget "förstör" signalkvaliten på oscillatorn när det kopplas in.
Untitled.jpg
 
Last edited:

SM5KYH

Well-Known Member
Vad mäter du med för instrument?
Om du använder en högohmig digitalmultimeter är det möjligt att instrumentet påverkas av din hf-signal och visar fel.
 
Top