Göra egen CAT kabel till Yaesu FT817/818

SA7ELF

Well-Known Member
Jag har under en tid med gott resultat kört med en styrkabel från RT systems till min Yaesu FT-818 men det finns lite fler signaler i ACC-kontakten på radion jag är nyfiken på och eftersom 8-polig mini-DIN är rätt liten och kompakt försökte jag hitta en färdig adapter-kabel av något slag och fann en liten kabel med 8-polig mini-DIN-hane i ena änden och en 9-polig D-sub-hane i andra. Den är ämnad för seriekommunikation mellan nån gammal MAC/Apple och PC. När jag mätte upp den insåg jag snart att långt ifrån alla stift var kopplade men följande 5 stift i ACC-kontakten kommer jag åt

RX D
BAND
GND
TX INH
TX D

Enligt följande github-sida borde RX, TX och GND vara tillräckligt och på sätt och vis är det det. När jag kopplar in kabeln mellan radion och min dator via en FTDI-adapter jag har till min arduino har jag dubbelriktad seriekommunikation och jag kan i WSJT-X läsa av frekvensen radion är inställd på och om jag ändrar i programmet uppdateras radion och om jag justerar på radion ändras det i programmet.

Problemet kommer vid sändning. Om jag trycker på TUNE i programmet så tänds röda lampan på radion och jag hör hur relät i SignaLinken drar och datorn skickar ljud via SignaLinken men jag får ingen output från radion. Jag kör inte med VOX utan WSJT-X aktiverar radions RF via CAT och enda skillnaden är CAT-kabeln, jag har inte ändrat på något av anslutningen på DATA-porten där ljudet går. Jag har även kontrollerat i ljudinställningarna i Windows att jag har output på rätt ljudkort. Ett tag tänkte jag att RT systems-kabeln kanske hade någon nedjordning av TX INH-pinnen men när jag provade att jorda ner den på min kabel blev det ingen skillnad. Kopplar jag tillbaka till den fungerande styrkabeln utan att ändra på någor mer förutom serieporten i WSJT-X har jag RF-output igen så det måste nästan vara något i ACC-porten jag missat.

Jag har för tillfället begränsade möjligheter att mäta på RT-kabeln och alla stift men inser att det kanske är det jag måste få till men jag tänkte höra här först innan ifall någon har stött på samma problem och vet vad lösningen är.
 

SM0IKR

Well-Known Member
Hej, det var ett tag sedan jag sålde min 817. Men 847'an vill ju ha en speciell "data-tx" ptt-signal. Har för mig att 817 var likandan. Skickar du rätt CAT-kommando? På 847 så gav man PTT via LF-kontakten.
 

SA0BUX

Old Member
Länge sedan jag körde min FT-817 men jag har för att man också behövde ligga i DIG mode för att kunna skicka och ta emot audio via DATA kontakten ?
 

SA7ELF

Well-Known Member
Det går säkert att använda PTT via SignaLinken men jag har valt att inte koppla in den pinnen å det har fungerat ypperligt hittils eftersom jag har satt radion i sändningsläge via CAT istället. När det gäller kommando kan jag inte riktigt svara på det eftersom jag inte vet exakt vad WSJT-X skickar men det är ju ingen direkt förändring annat än kabeln och serieporten.

COM2 är min FTDI-adapter och COM4 är RT systems kabel. Bägge kablar fungerar såtillvida att datorn kan kommunicera med radion och trycker jag på Test PTT tänds lampan som indikerar sändning på radion med bägge kablarna men om jag trycker på Tune är det endast med RT-kabeln som jag faktiskt sänder ut något. Det är inga andra skillnader såvitt jag kan se.
 

Attachments

  • com_compare_2.png
    com_compare_2.png
    75.5 KB · Views: 6
  • com_compare_1.png
    com_compare_1.png
    64.1 KB · Views: 5
  • com_2.png
    com_2.png
    34.2 KB · Views: 5
  • com_4.png
    com_4.png
    34.4 KB · Views: 6

SA7ELF

Well-Known Member
Snubblade över den här bilden som anger att det sitter ett internt pull-up-motstånd på RX. Kan det vara det som ställer till det för mig? Jag verkar ju ha fullt fungerande seriekommunikation så jag har svårt att tänka mig att det är det som är bekymret.
 

Attachments

  • FT-857-CT62-replacement.jpg
    FT-857-CT62-replacement.jpg
    56.7 KB · Views: 24

SA7ELF

Well-Known Member
Kan inte riktigt förklara orsaken till varför mitt första försök misslyckades men jag fick hem en ny USB-till-TTL-omvandlare och eftersom kabeln jag använda inte fungerade klippte jag av den på mitten, mätte upp stiften och anslöt den till den nya FTDI-omvandlaren och nu fungerar allt som det ska. De enda stiften som inte verkar vata anslutna i DIN-kontakten på min kabel är BAND-spänningen och ALC men det kan jag än så länge leva utan.

Kan sammanfattningsvis meddela att GND, TX och RX är de enda stift som verkar behövas för att kontrollera en Yaesu FT-818ND via TTL-serieport
 

sm5pnp

Well-Known Member
TX INH uppför sig precis som du beskriver, radion, 817 iofs, går över i TX läge men ger ingen uteffekt.
Jag strömförsörjer en aktiv RX loop från radion och då jordar jag TX INH.
 
Top