Linux och amatörradio

SM0KBW

Well-Known Member
Precis min erfarenhet oxå, NT-kärnan har ett oförtjänt dåligt rykte bland de i Unix-lobbyn.

Sedan XP och nu Win7 - som går att strama upp, har jag egentligen inte behövt Linux
utan det är mer som kuriosa man bootar upp något system då och då. Det trots att jag varit
med på Linux-tåget sedan Linus presenterade det på usenet.

Kan hända att man får gå tillbaks till LInux när 7:an tappar support från M$. För 8.1an vägrar
jag att köra och har t.o.m "uppgraderat" från 8.1 till 7:an på min laptop som levererades med
eländet.
 

SM2VJX

Riktig radioamatör!
Hittade en sida med Ham radio on Raspberry
Raspberry Connect - Ham Radio Packages
Finns en hel del men ändå ingår inte tex Gnuradio och rtlsdr-scanner som jag kör på min pi2
Med Kali-linux1.1
http://www.algonet.se/~sm7nzb/bilder/Kali110.JPG

/ 73 Tommy

Så lämpligt, jag har just i kväll sparkat igång en Raspberry Pi2 som jag spontanshoppade häromdagen.

När den hade installerat och bootat upp drabbades jag av den bekanta känslan "jaha, vad ska jag ha den här till"

Ungefär samma känsla infann sig när jag hade köpt en RTL-SDR och provkört den för ett tag sedan.

Det kanske går att kombinera dessa två spontanköp till något kul?
 

SM5XUN

░░░░░░░
Så lämpligt, jag har just i kväll sparkat igång en Raspberry Pi2 som jag spontanshoppade häromdagen.

När den hade installerat och bootat upp drabbades jag av den bekanta känslan "jaha, vad ska jag ha den här till"

Ungefär samma känsla infann sig när jag hade köpt en RTL-SDR och provkört den för ett tag sedan.

Det kanske går att kombinera dessa två spontanköp till något kul?

Man kan aldrig ha för många hallonpajer :)
Jag hängde på låset och lyckades köpa en B-version precis vid relaeasen, efter lite lekande kom jag till samma slutsats som du, "vad skall jag ha den här till?" och så sålde jag den.

Förra året blev jag lite nyfiken på Raspberry Pi igen och nu sitter jag här med tre stycken, en B, en B+ och en 2:a,
De rullar som d-star med ambe3000, en leker DAC med ett Wolfson piggyback kort och den tredje härbärgerar en DVB-T SDR remote på vinden via PoE.

Nu har jag inte testat att köra remote SDR på Pi2 men du kan ju få prova, det fungerar fint med vanliga B och B+ :
Raspberry Pi as Remote Server for RTL2832u SDR | Ham Radio Science


edit: Jag glömde ju en fjärde, den kör Xastir APRS :)
 
Last edited:

SA0MAD

Member
Jag för min del kör Debian, och där kunde jag bland annat enkelt dra ned och installera CQRLOG som verkar tillräckligt kompetent för mina ändamål. Saknas en del saker, t.ex. så har den ADIF export men inte Cabrillo export, som uppenbarligen behövs ibland. Vore ju lite fiifich om den kunde mata rakt in i SMFF, men man kan inte få allt och jag begriper att den kanske inte finns med. Att CQRLOG kör MySQL för databasen är lite betryggande, för då borde det vara exporterbart till vad som helst om det kniper, även om ADIF exporten nog är primär-vägen ut.

Det finns en hel del gott och blandat i hamradio foldern av program i Debian-distron, så man har nog att göra att testa igenom det först.

Pillat lite GnuRADIO och RTL-SDR, men inte fått allt att fungera som tänkt. Får pilla lite mer helt enkelt.
 

SM7NZB

Seniormoderator
Staff member
Ett tips om Gnuradio och Rtlsdr är att hämta hem Kali-Linux. På v1.09 får man addera
sdr som paket och sen fungerar det direkt.
http://www.algonet.se/~sm7nzb/bilder/Kali110.JPG
Gäller Raspberry pi2 alltså.

På,Ubuntu 15.04 på PC var det lätt också med Ubuntu-hams PPA, men har inte testat det med
Raspberry och Ubuntu 15.04 än.

/ 73 Tommy
 

SA0CNH

Well-Known Member
Höll på att starta en ny tråd men såg denna , i sista röda sekunden;)

Är intresserad av att kunna ställa upp och arrangera byggblocken i en SDR, med hälp av GNU Radio. Tankade hem Ubuntu 15.10 och installerade sedan programmet via pakethanteraren utan problem.
Tanken är att använda min FunCube Pro sticka för att lyssna på VHF/UHF banden. Till saken hör att det hela körs virtuellt i VM-Ware. (Vilket kanske gör saken svårare ? )
Just nu strular USB stödet mellan windows och Ubuntu. Ubuntu ser VM-Ware usb navet, men ingen Funcube. Får se om jag kan hacka till det. ( I windows 7 funkar stickan för att lyssna )

Någon på forumet som fått GNU Radio och Funcube Pro att lira OK ?
 
Last edited:

SA0CNH

Well-Known Member
Uppdaterade vm-ware till senaste versionen och då vips fick Ubuntu tag i Funcuben. Bra mottagning och rent ljud med GQRX SDR appen på FM bandet, och jag fick även in några repeaters.

I GNU Radion gick det bra att bygga up en FM mottagare med de färdiga byggblocken. Synd att det vart problem med syncen av audioströmmen inne i WideBandFM demulatorn
vilket gjorde att det som kom ut i högtalaren lät riktigt illa, ungefärs som en gammal CD spelare som skippar mellan bitarna :oops:
Några steg framåt iaf

Gnuradio - Funcube.jpg Gnuradio - Funcube2.jpg
 
Last edited:

SM7NZB

Seniormoderator
Staff member
Gqrx på Raspberry har ju krävt en specialutgåva direkt via upphovsmannen, men på Pi 4B med 4 GB minne så fungerar det att bara använda programhanteraren.

På mina laptops tycker jag bäst om Mint, nu 19.2, men testar lite WSJT_x på Ubuntu 18.04.

/ Tommy
 

SM0IKR

Well-Known Member
Hej alla!
Skiver vidare i denna tråden.
Nu har jag kört med en hallonpaj 4 i ett tag. Funkar finfint tillsammans med min gamla RigExpert Standard.
De program jag kör är lite olika pip&tut-program. Loggen kör jag fortfarande i PC-n. MEN Nu har jag sprungit på ett problem.
När jag skulle stoppa i MSHV så tog det stopp. "GLIBC_2.29 not found". Har BARA 2.28 i RaspianOS. Hur få dit en högre version?
Jag är inte ensam om problemet det har en sökning visat. Men inget bra svar. I Debian Bullseye finns det nyare men jag vet inte hur man får i det i Rasbian Buster.
HJÄLP!
 

SM6MUY

Well-Known Member
Jag fick igång MSHV en gång i tiden på en RPI 3B tror jag det var. Men en del handpåläggning och när jag väl fick igång den så funkade inte alla moder. Supporten var noll så gav upp. WSJT-x funkar direkt utan krångel men skall du köra FSK441 osv blir det ju problem...
 

Lars-Erik

New Member
Hej alla!
Skiver vidare i denna tråden.
Nu har jag kört med en hallonpaj 4 i ett tag. Funkar finfint tillsammans med min gamla RigExpert Standard.
De program jag kör är lite olika pip&tut-program. Loggen kör jag fortfarande i PC-n. MEN Nu har jag sprungit på ett problem.
När jag skulle stoppa i MSHV så tog det stopp. "GLIBC_2.29 not found". Har BARA 2.28 i RaspianOS. Hur få dit en högre version?
Jag är inte ensam om problemet det har en sökning visat. Men inget bra svar. I Debian Bullseye finns det nyare men jag vet inte hur man får i det i Rasbian Buster.
HJÄLP!

Först ska jag säga att jag inte alls kör MSHV eller sådär - men jag kör väldigt mycket linux. :)

Jag gissar att du har tagit en version härifrån, kan det stämma? Om man läser deras notering i dokumentet RASPBERRY-PI+README så skriver dom att det är kompilerat för Ubuntu på Raspberry PI. Man verkar inte gilla raspbian alls. Om man tittar i deras Archive-mapp så finns det dock lite äldre varianter som faktiskt är kompilerade för raspbian. Någon av dom kanske kan fungera? Annars är väl det bittra att man får kompilera en egen variant utifrån deras källkod.
Jag provade att kompilera den senaste versionen på min raspberry pi 4 och det fungerade faktiskt fint. Den versionen hittar du här om du är sugen på att prova. För att köra igång det så behöver du installera ett par grejor som jag vet behövs utifrån deras dokumentation. Det gör du genom att köra:

sudo apt install libfftw3-* libasound2-dev qt5-default

Det kan också möjligen vara fler paket som du inte har men som jag har haft installerat sedan tidigare. I så fall hoppas jag att den gnäller på vad den saknar. :p

Hursomhelst laddar du hem zipfilen, zippar upp den och kör programmet. Det fungerar åtminstone på min raspberry pi (se screenshot) med RaspianOS på. Om det funkar som det ska? No clue - jag kör mest wsjt-x på min.

Det går också att uppgradera från Buster till Bullseye ... det är en lösning jag skulle .. skjuta på om det var möjligt. Om du väljer att göra det, gör en backup av ditt minneskort innan. Det är mycket troligt att något kommer sluta fungera. Jag hittade en liten guide för hur man gör här.
 

Attachments

  • screenshot-2020-11-03-230536.png
    screenshot-2020-11-03-230536.png
    642.2 KB · Views: 12

SM0IKR

Well-Known Member
Hej Lars-Erik, toppenbra svar. Jo som du skriver så hade jag en fungerande version men den är gammal och måste uppdateras eftersom WSJT har bytt sätt att skicka rapporter i VHF-testerna.
Vet inte vad han som kompilerar har emot Raspberry OS nu.
Min förmåga att kompilera själv är dålig för att inte säga obefintlig, :)
TAck för din insats. JAg tror att jag har dessa paket redan. Jag kör i stort sett alla andra wsjt-kloner helt OK.
Jag har också kört med en "riktig" Ubuntu i pajjen. Då kör MSHV men då funkar inte USB-serieportarna.
När det gäller att hoppa upp på Bullseye så avstår jag gärna det. Så mycket tid o knöl behöver jag inte. Det händer tids nog ändå.
Återkommer med resultatet snart.....
vy 73 Göran
 

SM0IKR

Well-Known Member
Jo, den kör OK.
MEN
Funktionen var inte 100% men felsökte inte fullt ut eftersom den inte sparar inställningar etc.
Osäker på logfunktion också. Jag får helt enkelt avvakta uppdatering av glibc.
 

Lars-Erik

New Member
Jo, den kör OK.
MEN
Funktionen var inte 100% men felsökte inte fullt ut eftersom den inte sparar inställningar etc.
Osäker på logfunktion också. Jag får helt enkelt avvakta uppdatering av glibc.
Ah, det beror säkert på att jag inte inkluderade alla mappar/filer utan bara programmet som sådant. Jag räknade med att det skulle skapa upp dom där mapparna om dom behövdes. Men så var det inte då. :)

Jag har uppdaterat filen nu - om du laddar hem den igen och zippar upp så får du med de andra filerna också, det löser säkert det där. :)
 

SM0IKR

Well-Known Member
Nu så rullar det OK. Inget qso ännu men sparar data o skickar log till N1MM i pc´n etc....
Ska pilla till en genväg bara på skrivbordet.
JätteTACK!
 
Top