NanoVNA problem

SM0GLD

Vänsterhänt
Jag har just fått hem en NanoVNA-F och den fungerar i sig själv men......
När jag försöker ansluta den till datorn och köra programmet "VNAsaver" så kan inte programmet ansluta till vna'n.
Fler har haft samma problem inser jag när man söker men jag har inte hittat någon lösning på problemet.
Är det någon på forumet som har några tips?
 

SA0BUX

Old Member
Får du upp serieporten i Device Manager ?

Själv har jag en Noelec Nanovna H4 , vet inte om dom skiljer sig åt, har använt dels ett kinesiskt windowsprogram "NanoVNA" 1.0.3 som fans hos Noelec samt NanoVNA Saver 0.3.9.
 

SM0GLD

Vänsterhänt
Får du upp serieporten i Device Manager ?
Javisst får jag det och NanoVNA Saver 0.3.9 visar Com6 (VNA) så allt är frid och fröjd så långt.
När jag trycker på "Connect" så händer ingenting. Trycker jag en gång till så visar programmet "Disconnect" och stänger av.
Har nu provat "VNA qt" med samma resultat :(
 
Last edited:

SM7NTJ

Well-Known Member
Javisst får jag det och NanoVNA Saver 0.3.9 visar Com6 (VNA) så allt är frid och fröjd så långt.
När jag trycker på "Connect" så händer ingenting. Trycker jag en gång till så visar programmet "Disconnect" och stänger av.
Har nu provat "VNA qt" med samma resultat :(
Nano VNA Saver 0.3.9 stöder inte vissa varianter av -F modellen.
Läs known issues på:

73 de SM7NTJ Lorentz
 

SM0GLD

Vänsterhänt
Nano VNA Saver 0.3.8 har samma hyss för sig.
Provat med Mac OS och även där problem med "connect"
I Linux efter mycket specialfixande gick den igång men crashade efter en stund.
Det enda som funkar är Android appen men det ger mig ingen fördel.
Just nu måste jag koppla in telefonen innan jag sparar en fil annars är filen "försvunnen" i VNA-minnet som jag inte kommer åt.

Det lutar åt att programmet inte funkar under win10 pro OS ver. 20H2.
 

SM0GLD

Vänsterhänt
Fler som har samma problem tydligen.

"The current NanoVNA Saver 0.3.9 Windows executable is exhibiting Com port access error when used on Windows 10 Pro 64 bit version 21h1 (19043.1202).
NanoVNA Saver loads but when connecting device "Connec to device" the CMD window report the following:
"ettings: C:/Users/plohs/AppData/Roaming/NanoVNASaver/NanoVNASaver.ini
2021-09-14 17:27:45,081 - NanoVNASaver.NanoVNASaver - ERROR - Tried to open COM3 (NanoVNA) and failed: could not open port 'COM3': PermissionError(13, 'Access is denied.', None, 5)"
Tried on several differeny PC's with same OS version.
NanoVNA-F V2 connects OK with other applications on same PC's.
Any suggested solution?"
 

SM0GLD

Vänsterhänt
Nu har jag backat FW till 2.0 och sedan steg för steg installerat om varje FW fram till senaste 3.0.
Inget har fungerat men när jag installerade 3.0 så startade allt som förväntat men bara en gång.
Efter avstängning och återstart är jag tillbaka i samma problem som tidigare.
Kan NanoVNA Saver skriva sönder FW?
Konstigt att jag kunde uppgradera FW via en USB-port som inte funkar med programmet.
Har nu uppdaterat datorn till win10 OS till 21H1 men det hjälpte inte.
Hittade ett annat VNA-program som direkt kopplar upp vna'n och man kan manipulera alla stimilu.
Tyvärr kan programmet inte läsa ner data.

EDIT: Har nu kört "terminal" mot vna'n och det fungerar helt OK.
apparaten svarar på dom kommandon som är angivna i manualen.

Det är m.a.o. inget fel på usb-porten.

Nano VNA Saver 0.3.9 stöder inte vissa varianter av -F modellen.
Leverantören Sysjoint länkar till den versionen av NanoVNA Saver, dom måste väl ha provat.
 
Last edited:

SM6GXV

Korsdominant
Har Du kollat att mjukvaran inte ställer om COM-portsnumret när man startar
eller återinitierar kommunikationen?

Utan att veta vilket chips som används: FTDI noterade för några år sedan att
tillverkare clonade deras chips och använde FTDI's drivrutiner. Då man skrev
om dom så att dom endast skulle fungera med sina egna...
 

SM0GLD

Vänsterhänt
Har Du kollat att mjukvaran inte ställer om COM-portsnumret när man startar
eller återinitierar kommunikationen?
Jo det verkar nåt åt det hållet. Under Putty-sessionen bytte den plötsligt pid (port ID)
Man måste plugga ur usb-kabeln innan man startar om programmet.
Det räcker inte med att bara stänga av VNA'n med power-switchen.
 

SM0GLD

Vänsterhänt
Har nu fått ny hjälp att ladda ner och kompilera programmet för Linux.
Nu fungerar allt som det ska :) ......men bara på datorn med Linux alltså.
Jag är ju ingen linuxanvändare så jag måste troligtvis vänta på en ny windows-version av NanoVNA Saver.
 

SM0GLD

Vänsterhänt
Jag blir alltid misstänksam när det finns två program med liknande namn
Jo det känns osäkert men NanoVNA Saver-0.3.8-by-Sysjoint säger att det finns en ny version, 0.3.9 att ladda ner från github med direktlänk dit.
Ingen av versionerna fungerar i win10 pro tycks det.

För min del anser jag att jag har bevisat att min NanoVNA är helt frisk då den funkar m.h.a. ett terminalprogram och i Linux.
Dessutom funkar Android-appen.
Det är win10 pro 64bit som är problemet.
 

SA0BUX

Old Member
Tog och testade min NanoVNA-H4 v0.5.0 och NanoVNA Saver 0.3.9 x64 i Windows 10 Home 21H1 (x64 , finns det x86 windows 10 numera ? )
och det verkar funka utan något problem. Hade bara testat i Windows 7 x64 tidigare.
Dock ser jag att USB drivern verkar vara x86:

1633979954672.png
 

SA0BUX

Old Member
Har inte uppdaterat någon firmware än , inser att 0.5.0 nog är ganska gammal , men har inte forskat i om det är något speciellt med denna
Nooelec NanoVNA-H4 och rätt firmware, köpte den ganska nyligen för att komplementera MiniVNA Pro som bara går till 200 MHz.
 

SM0GLD

Vänsterhänt
Jag köpte min NanoVNA av samma skäl som du, behövde högre frekvens.
Dessa båda varianter, H4 och F, har samma ursprung i grunden men firmware är förståss olika.

Jag har skickat ett mail till leverantören och försökt förklara problemet så noga jag kan. Hoppas få svar inom några dagar.

Det jag får göra nu är att spara mina svep och överföra filerna till datorn och öppna dom m.h.a. NanoVNA Saver.
Lite bökig omväg men det är det enda alternativet just nu. Helst vill jag ju jobba med stor skärm direkt.
 

SA0BUX

Old Member
Uppdaterade till FW v1.0.69 och fortfarande inga problem, däremot hade jag problem tidigare när jag skulle köra MiniVNA'n på denna dator.
Dom VNA programmen gillade inte mina com0com drivers för virtuella com portar, så jag fick disabla en del i device manager då.
 
Top