PTT interface koppla LPT1 kabeln

peter1991

Member
hej Har byggt ett enkelt PTT interface som jag ska andvända till
mitt ljudkort för att sända packet singnaler via
men när jag kopplar sladdarna till datorn och skal testa
sända så händer ingenting snälla hjälp mig är det något jag gjort fel som måste ändras?
talla gärna om det är nämligen ny börjare.
sickar met elskemat
fig02_367.jpg


//peter


:) :) :) :) :)
 

M0DFI

Well-Known Member
Peter,

Vad du har beskrivit är nog egentligen inget att rekommendera!

Kolla in http://patmedia.net/ralphmilnes/soundcardpacket/1cableptt.htm

- där hittar du en optisk isolerad PTT koppling. På detta sätt sparar du snart in en hel del pengar i reparationskostnader.

Kom ihåg att de flesta nätaggregat in PC's är milt sagt dåliga och byggda med billiga komponenter. Ett vanligt fel är just jordfel...


//Dan, M0DFI
 

SM5KRI

Oldtimer
M0DFI said:
Peter,

Vad du har beskrivit är nog egentligen inget att rekommendera!

Kolla in http://patmedia.net/ralphmilnes/soundcardpacket/1cableptt.htm

- där hittar du en optisk isolerad PTT koppling. På detta sätt sparar du snart in en hel del pengar i reparationskostnader.

Kom ihåg att de flesta nätaggregat in PC's är milt sagt dåliga och byggda med billiga komponenter. Ett vanligt fel är just jordfel...


//Dan, M0DFI


Den kopplingen som Dan nämner har jag använt i flera år för att nyckla CW via contestlogg-programmen. Men tänk på att det kanske inte alltid fungerar att nyckla via parallellporten på datorn om man har win XP eller 2000. Det funkar bra om man har win 98 elller liknande. Ett bättre alternativ är att nyckla via serieporten. Mellan datorns ljudkort och modemet ska det väl vara galvaniskt isolerat också, inte bara PTT-styrningen.
 

SM7WDG

Well-Known Member
SM5KRI said:
Den kopplingen som Dan nämner har jag använt i flera år för att nyckla CW via contestlogg-programmen. Men tänk på att det kanske inte alltid fungerar att nyckla via parallellporten på datorn om man har win XP eller 2000. Det funkar bra om man har win 98 elller liknande. Ett bättre alternativ är att nyckla via serieporten. Mellan datorns ljudkort och modemet ska det väl vara galvaniskt isolerat också, inte bara PTT-styrningen.


Kopplingen som är av modellen "KISS" modellen ;-) , funkar UA , dock vill jag bara ge ett par tips till alla som använder sig utav dessa kopplingarna att stänga av Plug & Play på parallell porten då detta kan gå in och störa nycklingen och till o med göra så att LPT porten blir helt inaktiv. Detta gäller främst i 32 bitar OP , Win 2000 , XP, NT.

Lycka till !!

// Freddy
 
Last edited:

SM4HFI

Well-Known Member
Hej!
Jag ser inte att peter1991 fått svar, bara att andra använder samma koppling.
Min första reaktion på schemat är att 10 kOhm verkar mycket. 5V ut ur parallellporten ger drygt 4V över motståndet och ca 0,4 mA genom det in i basen, Transistorn förstärker runt 100 gånger, så den drar max 40 mA utan marginaler. 1 kOhm ger nog inte 10 gånger mer ström, men borde dra de flesta PTT även om det är ett relä.

Så felsökning:
Finns det spänning ut på motståndet när du aktiverar PTT i programmet?
Blir det 0,7V på basen när PTT aktiveras?
Kräver PTT i riggen mer ström än transistorn kan sänka?

Optoisolator är bra, men jag har heller inte kört någon på läänge...

73! /Jan
 

M0DFI

Well-Known Member
SM4HFI said:
Hej!
Jag ser inte att peter1991 fått svar, bara att andra använder samma koppling.

Så felsökning:
Finns det spänning ut på motståndet när du aktiverar PTT i programmet?
Blir det 0,7V på basen när PTT aktiveras?
Kräver PTT i riggen mer ström än transistorn kan sänka?

Optoisolator är bra, men jag har heller inte kört någon på läänge...

73! /Jan


Meddelandet som jag vill få fram var: "Ge tusan i att koppla riggen direkt till din PC!"

Det verkar som om många PC's hamnar i shacket efter att de pensionerats från att vara hemdator/speldator eller tjänstedator. Detta brukar översättas till att vara äldre än ett år eller två.

I många ( många många ) fall så läcker filter kondensatorerna i PC nätaggregaten och vu brukar kunna mäta runt 110 -120 Volt AC mellan nätaggregatets chassio och vägguttagets skyddsjord.

Om detta problemet uppstår, vilket blir billigast - optokopplare eller reparation av riggen?

Vän av ordningen kan nu påstå att det är OK att koppla ihop riggen och PC'n galvaniskt bara man har en riktig skyddsjord. Detta är i princip riktigt MEN!! bara så länge alla kontakter är isatta! Så fort du tar ur ett nätuttag någonstans så riskerar du att momentant få en hög potential mellan någon/några burkar.

- Visst, man kan skruva fast en kopparfläta mellan alla apparatchassi'n men detta är inte alltid en bra lösning då s.k "ground loops" kan uppstå.

Så jag skulle nog vilja råda till att aldrig koppla ihop rigg och datorer galvaniskt!

Så till felsökningen...

Om du kopplar ihop din rigg och PC galvaniskt, räkna med att du får varierande potentialer mellan stiften på din koppling. Transistorn kommer att riklikta eventuell krypströmmar och du skall inte räkna med att din koppling fungerar från dag till dag - om transistorn överlever med 110V AC på ingång/utgången...

För att felsöka så rekommenderar jag att du mäter med ett oscilloskåp. Lägg inte tid på attt mäta med en DVM, låna ett oscillokåp - kolla med radioklubbarna.


//Dan, M0DFI
 

SM5KRI

Oldtimer
M0DFI said:
Meddelandet som jag vill få fram var: "Ge tusan i att koppla riggen direkt till din PC!"

/snip/
I många ( många många ) fall så läcker filter kondensatorerna i PC nätaggregaten och vu brukar kunna mäta runt 110 -120 Volt AC mellan nätaggregatets chassio och vägguttagets skyddsjord.

/snip/

Så jag skulle nog vilja råda till att aldrig koppla ihop rigg och datorer galvaniskt!

//Dan, M0DFI

Håller med,
Det var exakt det problemet jag hade med första PC:n jag köpte i mitten av 90-talet, en IBM Pentium 120 MHz, som sedemera ersattes av ny och snabbare dator för familjen några år senare och IBM:en hamnade i schacket som packet- logg- och contest -dator. Jag upptäckte då just den spänningen mellan jord och chassie, när jag experimenterade med olika kopplingar för att aktivera PTT och köra packet och CW m.m. Ljudkortet jag hade då isatt pajade och då förstod jag att det behövdes ett interface som var isolerande för att få det fungera för mig. Blev ett nytt ljudkort och interface via opto som funkade utmärkt. Ville inte heller äventyra en rigg som då kostat mig 20.000 i inköp.

Numera finns den datorn på tippen sedan länge ..
 
Last edited:
Top