1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TS 590S och Win-Test

Discussion in 'Program för amatörradio' started by RM2D, Aug 13, 2013.

  1. RM2D

    RM2D Well-Known Member

    Jag har med någon dator tidigare lyckats få Win-Test och TS 590 S kommunicera perfekt. Det var ett tag sedan och tydligen har jag glömt bort hur jag gjorde förra gången...

    Har köpt ny dator och vill nu konfigurera den för TS 590S

    Jag har laddat ner en VCP (Variabel COM Port) driver och installerat den innan jag kopplade in USB-kabeln mellan rig och dator.

    COM-porten som föreslogs var COM13 och jag har manuellt bytt den till COM2 (man rekommenderar COM-port under 10 eller något sånt).

    Följande inställningar i Win-Test används: 4800 Bits per second, 8 data bits, Parity-None, 2 Stop Bits DTR (pin 4) OFF, RTS (pin 7) OFF

    Radion är ställd på 4800 Bits per second (meny 62)

    Följande händer:

    Jag kan byta band på radion via Win-Test, men då jag försöker bytar band med radion följer inte datorn med.

    Då jag rör VFO på radion följer inte datorn med heller.

    Det verkar som datorn styr radion, men inget kommer åt andra hållet? Någon inställning i TS 590S som jag glömt aktivera? Hastigheter eller andra COM karäkteristika som är fel?

    73 de LRR

    Har Win-Test 4.10.0 samt Windows XP Professional 2002, Service Pack 3
     
    Last edited: Aug 13, 2013
  2. sa0bga

    sa0bga Well-Known Member

    Hej Mats

    Rent spontant, ska det verkligen vara 2 stop bitar? Normalt vid seriell kommunikation via datorn på det sättet är det 1 stop bit. Å andra sidan skulle du med all säkerhet inte få upp kommunikationen åt något håll om detta var felet.

    Spontant nr 2. Är du säker på att alla stift i kabeln är hela? Tx i kabeln från datorn till radio verkar fungera då du kan styra från datorn men Rx in till datorn eller Tx från radio verkar inte lira i och med att du inte får den responsen tillbaka till datorn.

    Har du provat att byta kabel?


    73 de SA0BGA
    //Niclas

    Edit:
    Å andra sidan kör du med usb-kabel direkt in i riggen misstänker jag nu... Visserligen är usb-kabeln seriell men intelligensen sitter i radion som där agerar usb till seriell omvandlare?
    Intressant :)
     
    Last edited: Aug 13, 2013
  3. RM2D

    RM2D Well-Known Member

    Hej Niclas,

    Vi prövar och byter kabeln först. Har ett par likadana liggande någonstans...

    2 stoppbitar verkar vara standardinställning då man trycker på "Default settings TS 590S" och dessutom för en massa andra radiotyper.

    Återkommer efter test med ny kabel, men undrar om det är det som är felet. Misstänker dock att det är något annat som spelar ett spratt.

    73 de LRR, Mats


     
  4. RM2D

    RM2D Well-Known Member

    Inställning för Win-Test med TS 590S och USB-kabel ska vara:

    115200 Bits per second, 8 data bits, Parity-None, 1 Stop Bits DTR (pin 4) HANDSHAKE, RTS (pin 7) HANDSHAKE

    Radion är ställd på 115200 Bits per second (meny 62)

    Funkar hur bra som helst nu.

    73 de RM2D, Mats
     

Share This Page